How to get wxJavaScript and Apache to play together nicely

There’s a note on the help page, under the section Installing server-side functionality that states:

Depending on your requirements, you may need to compile the mod_wxjs source.

What this really means is that the version of mod_wxjs supplied in the Remote Writer download is compiled against a certain version of Apache server, and that if you install a different version of Apache (say, by installing the most current version from the Apache site), mod_wxjs will therefore need to be recompiled against this newer version of Apache.

In version 0.0.20 of Remote Writer, the version of Apache that mod_wxjs is compiled against is 2.2.3, therefore if you don’t want to go to the hassle of recompiling mod_wxjs, then simply install this Apache 2.2.3 version from the Apache archive (if working on windows, you’ll want one of these binaries).

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: